Doppelten Content vermeiden

Es dürfte bekannt sein, dass Suchmaschinen Webseiten schlechter bewerten, wenn diese doppelte Inhalte vorweisen. So versucht also jeder, möglichst individuellen Content zu erstellen und nicht ganze Absätze zu kopieren.
Das ist auch schön und gut, doch nützt das alles nichts, wenn der Webmaster die Domain als solche nicht beachtet. Eine Domain kann normal immer entweder mit domain.tld oder aber mit domain.tld aufgerufen werden. Für den Normalbenutzer ist das die selbe Adresse, jedoch nicht für Suchmaschinen.
Diese indizieren nun beide Seiten separat und finden somit vollkommen identischen Inhalt ("Content"). Somit wird die eigene Website, obwohl sie eigentlich vollkommen richtig aufgebaut ist, schlechter eingestuft.

Man sollte also immer einen kleinen Code in eine .htaccess schreiben und diese in das root-Verzeichnis der Domain legen. Der Code ist dann wie folgt:

Quellcode

  1. RewriteEngine On
  2. RewriteCond %{HTTP_HOST} ^www\.domain\.tld$ [NC]
  3. RewriteRule ^(.*)$ http://domain.tld/$1 [R=301,L]
In diesem Falle wird die Adresse von domain.tld nach domain.tld geleitet. Will man es anders herum, also von domain.tld nach domain.tld, so ändert man den Code einfach so ab:

Quellcode

  1. RewriteEngine On
  2. RewriteCond %{HTTP_HOST} ^domain\.tld$ [NC]
  3. RewriteRule ^(.*)$ http://www.domain.tld/$1 [R=301,L]
Aktiviertes mod_rewrite im Apache und vergleichbares im IIS o.Ä. ist dazu Pflicht.
Über den Autor
Ich bin Webentwickler in Stuttgart und administriere Server seit vielen Jahren. In diesem Blog erstelle ich hauptsächlich Tutorials für andere Webentwickler, Webdesigner und Serveradministratoren.
-------------------------------------------------------------------------------------------------------------------------------------
I’m a web developer in Stuttgart, Germany, and server administrator since many years. This blog mainly contains a tutorial set for other web developer, web designer and server administrators.

2.174 mal gelesen

Kommentare 32

  • eCityWolf -

    Super geklappt!

  • kleinefarm -

    Danke für diese Beschreibung Matze, ich habe sie inzwischen schon mehrfach gebraucht.

  • Black Rider -

    Unter Lighttpd kannst du das in der Serverkonfiguration angeben:
    redmine.lighttpd.net/projects/…/Docs_ModRedirect#Example

    Oder auf Deutsch:
    sebastianconstapel.de/seo/saub…edirect-mit-lighttpd.html

  • Chris-Chris -

    Hiho, danke für Deine Erklärung, sehr schön und verständlich geschrieben! Wie würde die Konfiguration für einen lighttpd Server aussehen? =)
    LG

  • Sunset -

    Ja, ich benutze Webspace.

    Okay, ich werd mal meinen Hoster fragen.

  • Black Rider -

    Was soll ich hier groß erklären? Ich nehme an, du nutzt nur einen Webspace. Oftmals ist nicht öffentlich einsehbar, ob mod_rewrite, eine Modifikation für den Webserver, aktiv ist. Daher am besten mal deinen Hoster fragen.

  • Sunset -

    Ich gehe davon aus...
    Das ist eben das HTML-Verzeichnis wo automatisch dieser Confixx-Anzeige kommt.

    Das mit dem mod_rewrite hab ich nicht so ganz verstanden. Kannst du mir das nochmal erklären?

  • Black Rider -

    Liegt die .htaccess-Datei auch in dem Ordner, der unter freaky-village.com zu erreichen ist?
    Ist außerdem mod_rewrite überhaupt aktiv?

  • Sunset -

    Funktioniert leider weiterhin bei mir nicht.
    Cache und Cookies habe ich vorsorglich schon mal geleert.

  • Black Rider -

    Achso. Dann geht es so:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^freaky-village\.com$ [NC]
    RewriteRule ^(.*)$ freaky-village.com/ordner/$1 [R=301,L]

  • Sunset -

    Ne, ich will ne Umleitung von freaky-village.com auf freaky-village.com/ordner

    Die WWW-Weiterleitung habe ich ja schon gemacht.

  • Black Rider -

    Du willst eine Umleitung von www. zu http:// ?
    Dann musst du die .htaccess-Datei nur in das Verzeichnis des Forums kopieren. Dann wird auch das Verzeichnis domain.tld/ordner/ zu domain.tld/ordner/ umgeleitet, so wie gewünscht.

  • Sunset -

    Das Forum soll ich ja nicht umgeleitet werden.
    Also ich bin gerade einfach echt zu doof dafür.
    Das Forum liegt im Ordner WBB.
    Und die Umleitung soll auf den Ordner WBB gehn.
    Weil bei freaky-village.com ist ja auch nur eine Weiterleitung auf den Ordner WBB.

    Rider, kannst du versuchen mir das noch einmal genau zu erklären? Ich versteh es gerade wirklich nicht.
    Muss ich nicht irgendwie, irgendwo angeben, dass der auf den Ordner WBB zugreifen soll?

  • Black Rider -

    Du musst die entsprechende Datei in das Verzeichnis deines Forums kopieren, so dass beim Aufruf des Forums dieses auch umgeleitet wird. ;)

  • Sunset -

    Rider, ich bin leider total bescheuert....
    Bei mir funktioniert das absolut gar nicht. *heul*
    Ich hab jetzt die Datei in das html-Verzeichnis gelegt, wo alle weiteren Ordner mit meinen Daten und mein Forum drin liegen. Aber es geht einfach nicht.
    Vorsichtshalber hab ich nochmal die Datei in den Ordner WBB gepackt... Geht trotzdem nicht.
    Bin ich irgendwie zu blöd?
    Mein Code ist folgender:
    [code]RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.freaky-village\.com$ [NC]
    RewriteRule ^(.*)$ freaky-village.com/$1 [R=301,L][/code]

  • evaioan -

    Danke Black Rider! :)

  • Black Rider -

    Du müsstest die .htaccess-Datei lediglich in beide Verzeichnisse legen. Das würde schon reichen.

  • evaioan -

    Huhu,

    eine Frage habe ich nocht! :D

    Genügt es, wenn ich nur die Domain umleite oder soll ich das Forum bzw. das Portal auch umleiten?
    Google hat meine Webseite, Portal und Forum auch unterschiedlich bewertet.
    Meine Webseite hat Ranking 1, das Portal 2 und das Forum wurde überhaupt nicht bewertet ....

    Schönen Sonntag und liebe Grüße
    Eveline

  • Black Rider -

    Dann war das wohl ein Fehler von mir :whistling:
    Habe es im Artikel auch mal ausgebessert!

  • evaioan -

    Jetzt funktionier es, du bist ein Schatz! :thumbsup:

    Danke für deine Geduld!

    Liebe Grüße
    Eveline

  • Black Rider -

    Versuche mal noch, an die letzte Zeile hinten ein [R=301,L] zu hängen, also so:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rheuma-selbst-hilfe\.at$ [NC]
    RewriteRule ^(.*)$ rheuma-selbst-hilfe.at/$1 [R=301,L]

  • evaioan -

    Jetzt bekomme ich eine Fehlermeldung:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@l.......r.ch and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    --------------------------------------------------------------------------------

    Apache/1.3.36 Server at rheuma-selbst-hilfe.at Port 80

    Dann scheint wohl das mod_rewrite nicht aktiviert zu sein. Ich war mir sicher, dass das aktiviert ist ....
    Danke dir für deine Mühe, ich werde es wohl lassen.

    Danke! Eveline

  • Black Rider -

    Probier es mal so:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rheuma-selbst-hilfe\.at$ [NC]
    RewriteRule ^(.*)$ rheuma-selbst-hilfe.at/$1

    Du hattest jeweils ein / zu viel nach "rheuma-selbst-hilfe" ;)

  • evaioan -

    Jetzt habe ich es so versucht:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rheuma-selbst-hilfe/\.at$ [NC]
    RewriteRule ^(.*)$ rheuma-selbst-hilfe/.at/$1

    und es geht auch nicht. Bin zu doff dafür :(.

    Schönes Wochenende!

  • evaioan -

    Das sieht jetzt so aus:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rheuma-selbst-hilfe.at/\.tld$ [NC]
    RewriteRule ^(.*)$ rheuma-selbst-hilfe.at/.tld/$1

    ... Das "tld" habe ich nicht geändert ... kenne mich damit ja nicht aus :D

    Jetzt muss ich wohl das "at" im Code entfernen und bei "tld" einsetzen?

    Werde es gleich testen.

    Danke dir!

  • Black Rider -

    Wie sieht denn dein Eintrag in der .htaccess denn im Moment aus? Du musst nicht nur "domain" in Zeile 2 und 3 ändern, sondern auch "tld" zu deiner Domain-Endung, z.B. "de" ;)

  • evaioan -

    Guten Morgen!

    Meine Fragen waren deshalb, weil ich schon alle Möglichkeiten durch hatte.
    Habe nach Anleitung alles gemacht und werde weiterhin nicht umgeleitet :(

    Schönes Wochenende!

    LG
    evaioan

  • Black Rider -

    Diese Änderungen betreffen alle Benutzer und ja, natürlich musst du deine Domain einsetzen ;)

  • evaioan -

    Zwei Fragen hätte ich noch:

    sehe ich die Umleitung auch? Also wenn ich auf die Seite ohne www. gehe, werde ich auch auf die Seite mit www. weiter geleitet? Oder ist das nur für die Suchmaschinen der Fall?

    Muss ich im Code "domain" mit meinem Domainnamen ersetzten? Ich habe es mit und ohne Änderung versucht. Ich alls User sehe keine Veränderung ...

    Liebe Grüße
    evaioan

  • evaioan -

    Danke Dir! :)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen